IPB

Здравствуйте, гость ( Вход | Регистрация )

 
Ответить в эту темуОткрыть новую тему
> ЗиК 7.7 v2.3 Проблема с автонумерацией в документе!, особенная проблема!
Gin
сообщение Nov 14 2006, 10:00
Сообщение #1


Начинающий
*

Группа: Пользователи
Сообщений: 5
Регистрация: 8-November 06
Пользователь №: 8961



Такая проблема:
В документе НачисленияУдержанияСотрудника (Ввод расчета сотруднику) сблилась автонумерация кода!
Тип кода - текстовый, там все стандартное стоит (контроль целостности, автонумерация итд...)
При вводе документа на номере 000298 нумерация слетает!
Удаляешь несколько последних документов - нумерация идет нормально, как только доходит до 298 номера - номера в документе нет!!!
Говорят такие проблемы бывают!
Плиз, подскажите как их решать!!!!

PS И неправельных кодов там нет! В том-то и проблема! там все номера идут от 000001 до 000297, а на новом номере - глюк!
PPS Если вручную поставить следующий номер - АВТОнумерация не возвращается! (проверели - ввели штук 20-30 следующих номеров)
Вернуться в начало страницы
 
+Ответить с цитированием данного сообщения
lesna
сообщение Mar 31 2007, 21:46
Сообщение #2


Начинающий
*

Группа: Пользователи
Сообщений: 5
Регистрация: 31-March 07
Пользователь №: 11093



Попробуй обработку ReNumber кажется называетя, есть на дисках ИТС.
Вернуться в начало страницы
 
+Ответить с цитированием данного сообщения
Одинец
сообщение Aug 13 2008, 12:11
Сообщение #3


Пользователь
**

Группа: Пользователи
Сообщений: 42
Регистрация: 8-October 03
Пользователь №: 700



Попробуй в Процедуру ВводНового(Копирование)
добавить строчку:
ПрефиксАвтоНумерации("Документ.НачисленияУдержанияСотрудника ","000");
или что-то типа:
УстановитьНовыйНомер();
задав нужные параметры, тогда что-нибудь да получится...
Вернуться в начало страницы
 
+Ответить с цитированием данного сообщения

Ответить в эту темуОткрыть новую тему
1 чел. читают эту тему (гостей: 1, скрытых пользователей: 0)
Пользователей: 0

 



RSS Текстовая версия Сейчас: 20th June 2019 - 15:05