IPB

Здравствуйте, гость ( Вход | Регистрация )

Фото
 
vlf
Продвинутый
42
Волгоград
Октябрь-21-1975
Интересы
Системы ИИ, 1С, Системное программирование, Радиотехника
9-July 04
8065*
5th March 2012 - 08:06
Nov 23 2017, 03:52
122 (0 сообщений в день)
AIM Нет данных
Yahoo Нет данных
ICQ 272774776
MSN Нет данных
Контакт E-mail скрыт

vlf

Пользователи

***


Темы
Сообщения
Blogs
29 Feb 2012
Требуются программисты для внедрения и доработки УПП 8.2.
Объект: Машиностроение, Москва, Московская область.
Возможна дистанционная работа.
Рабочие офисы: Волгоград, Москва.
25 Sep 2006
Комплекс защиты перестал запускаться, даже скопированый с оригинального диска на любой машине.
На hotline письмо отослал, жду ответа
29 Aug 2005
Ситуация:
Написана ВК: По таймеру каждую минуту выполняется запрос к 1 таблице БД. Подключение к SQL статично, на все время работы. Двадцать пользователей-> прямые обращения хаотично постоянные каждые 3 сек.

Две недели проработало нормально.

На третью неделю произошел ОГромный сбой.
При проведении документа не отработалась процедура ЗафиксироватьТранзакцию - спутались идентификаторы документов и проводки.

Вопрос: как 1с отрабатывает НачатьТранзакцию и ЗафиксироватьТранзакцию.
Переводит ли 1с-ка SQL на это время в single user?
Если да, то как во внешнем запросе отслеживать single user.

Проблема актуальна для всех кто пытается выполнять обращение к БД 1С внешними средствами.

Надеюсь на помощь корифеев.
4 Aug 2005
Пишу ВК. Цель - внешний шедулер напоминаний (без кода 1С, на этапе исполнения.) Сейчас напоминания регистрируются во внешней компоненте путем вызова соответствующего метода.

Можно ли список напоминаний забирать из SQL таблицы. Как это сделать кодом небольшого объема на С.
23 Jul 2005
Хотелось бы поделиться своими наработками по ускорению исполнения кода.
Надеюсь на поддержку данной ветки и ваши примеры!
Пример должен быть ясным и полным.

Итак
RIGHT JOIN на 1с
Код
тзГруппы=СоздатьОбъект("ТаблицаЗначений");
тзГруппы.НоваяКолонка("Прочее");
//***********
тзГруппы.НоваяКолонка("Товар");

//******** запоняем тзГруппы

тзТовары=СоздатьОбъект("ТаблицаЗначений");
тзТовары.НоваяКолонка("Товар");
//***********
тзТовары.НоваяКолонка("Прочее");

// SELECT FROM тзГруппы RIGHT JOIN тзТовары ON тзТовары.Товар=тзГруппы.Товар

тзТовары.Сортировка("Товар");

тзГруппы.ВыбратьСтроки();
Пока тзГруппы.ПолучитьСтроку()=1 Цикл
   стр="";
   Если тзТовары.НайтиЗначение(тзГруппы.Товар,стр,"Товар")=1 Тогда
          Для ё=стр по тзТовары.КоличествоСтрок() Цикл
                 тзТовары.ПолучитьСтрокуПоНомеру(ё);
                 Если тзТовары.Товар<>тзГруппы.Товар Тогда
                         Прервать;
                  КонецЕсли;

             // Здесь имеем соединение таблиц

          КонецЦикла;
    КонецЕсли;
Конеццикла;
Гость


24 May 2017 - 23:57


9 Jul 2009 - 12:49

vlf.

.
RSS Текстовая версия Сейчас: 23rd November 2017 - 02:52