IPB

Здравствуйте, гость ( Вход | Регистрация )

Фото
 
ezh .
ezh
Туманный ёжик
39
г.Москва
Март-27-1980
Интересы
Нет данных
5-January 04
2984*
9th February 2012 - 09:30
Jul 24 2019, 04:02
618 (0 сообщений в день)
AIM Нет данных
Yahoo Нет данных
ICQ 11561982
MSN Нет данных

ezh

Эксперты

***


Темы
Сообщения
Blogs
27 Jul 2005
Телепат v2.0.0.0q

Код
Процедура Бла()
 Сумма = 123456;
КонецПроцедуры


Если теперь поставить точку, например, вот так:

Код
Процедура Бла()
 Сумма = 1234.56;
КонецПроцедуры


то intelliSense напишет "КонецПроцедуры"

Сорри, если это уже известно, и тем более сорри, если это не косячЁк ;-)
8 Jun 2005
Тут оригинал.

А вот коротко:

Копирайт Dionisious

1Cv8

// Возвращает имя значения перечисления
//
// Параметры
//  Ссылка  – ПеречислениеСсылка – ссылка на значение перечисления, имя которого
//                 надо получить
//
// Возвращаемое значение:
//   Строка   – имя значения перечисления
//
Функция обИмяПеречисления(Ссылка) Экспорт

ИмяПеречисления = Ссылка.Метаданные().Имя;
Индекс = Перечисления[ИмяПеречисления].Индекс(Ссылка);

Возврат Метаданные.Перечисления[ИмяПеречисления].ЗначенияПеречисления[Индекс].Имя;

КонецФункции // обИмяПеречисления()
11 Oct 2004
Требуется: Руководитель проектов

Характер работы: Руководство крупными проектами по автоматизации предприятий
(от предпроектного обследования до сдачи в эксплуатацию; постановка задач для разработчиков и
внедренцев; ведение переговоров).

Требования: Высшее образование (экономическое, техническое), умение работать в команде,
опыт руководства сложными проектами. Желательно знание 1С:Предприятия, OLAP - технологий.

З/П: 1500$ (По итогам собеседования)

Контактная информация: Ерохин Глеб, erohin@business-analysis.ru
6 Oct 2004
Следующие два фрагмента идентичны. Выполняются без ошибок.

1Cv8

Попытка
 ВызватьИсключение "Ошибка 911"; // <--
Исключение
 Сообщить("Исключение: " + ОписаниеОшибки());
КонецПопытки;


1Cv8

Попытка
 ВызватьИсключение("Ошибка 911"); // <--
Исключение
 Сообщить("Исключение: " + ОписаниеОшибки());
КонецПопытки;


Я уже не говорю о том, что по документации ВызватьИсключение вообще не имеет параметров (возможно в новой документации исправлено - у меня ее нет).
28 Sep 2004
См.прикрепленный файл.

Применение:
Корректная запись подчиненных элементов без указания владельца (без записанного владельца).

зы: Обратите внимание на различие реализации добавления контактного лица в справочнике Банки и Компании. Различие связано с тем, что справочник Банки не иерархический, а Компании - иерархический.

зы2: Спасибо Тюшкину Андрею за помощь в исследовании особенностей работы с иерархическими справочниками.
Прикрепленные файлы
Прикрепленный файл  SetNewObjectRef.dt ( 22.08 килобайт ) Кол-во скачиваний: 435
 
Гость


29 Dec 2017 - 2:14


15 Nov 2009 - 13:37
SWG


4 Apr 2009 - 10:45


27 Nov 2008 - 21:04


30 Oct 2007 - 15:39

ezh.

.
RSS Текстовая версия Сейчас: 24th July 2019 - 03:02