IPB

Здравствуйте, гость ( Вход | Регистрация )

Фото
 
Cosmos .
Cosmos
Продвинутый
Интересы
Нет данных
9-August 06
5657*
2nd June 2011 - 04:51
Jul 22 2019, 07:01
443 (0 сообщений в день)
AIM Нет данных
Yahoo Нет данных
ICQ Нет данных
MSN Нет данных

Cosmos

Пользователи

***


Темы
Сообщения
Blogs
1 Jun 2011
Хочу исправить расчетный листок В ЗУПе и открываю макет "Расчетные листки" .Выходит табличка с заголовком "Двоичный код " и предложением "Загрузить файл " , "Выгрузить файл " . Как оботйти эту штуку .Выгрузить и отредактировать ? 1с открывает но как текстовый файл .
25 Nov 2008
Работаю с файлами XML и встречаюсь с одной вещью- а именно ., нужно обходить нижний уровень вложения и только его .
Программно я задаю что произошел конец уровня и прервать цикл. иначе выйдет за пределы уровня элемента .
Пока ФайлОбмена.Прочитать() Цикл
Если ФайлОбмена.ТипУзла = ТипУзлаXML.НачалоЭлемента Тогда
трам тарарам
ИначеЕсли (локИмя = ФайлОбмена.ЛокальноеИмя) И (ФайлОбмена.ТипУзла = ТипУзлаXML.КонецЭлемента) Тогда
Прервать;
КонецЕсли;
ОбработкаПрерыванияПользователя();
КонецЦикла;
а аналог типа ФайлОбмена.Спуститься() (как в 7.7) и лабать файл тока по этому уровню есть в 8?Если имя уровня вдруг совпадет с вложенным именем то обработка прервется ещё не дойдя до конца .
в помощи только такие ограниченные вункции
14 Nov 2008
Есть регистр сведений контактнаяИнформация в ней лежат адреса по прописке и факт
Когда я переношу их все вместе то они сохраняются .Если по отдельности то последний затирает предыдущие данные
вот код которым пользуюсь
[/indent]
НаборЗаписей = РегистрыСведений[ПромВид1].СоздатьНаборЗаписей();
Если ПромВид1 = "КонтактнаяИнформация" Тогда
НаборЗаписей.Отбор.Объект.Значение = ТекОбъект.Ссылка;
НаборЗаписей.Отбор.Объект.Использование = Истина;
КонецЕсли;
Если Ком = "Телефон" Тогда
Запись = НаборЗаписей.Добавить();
Запись.Объект = ТекОбъект.Ссылка;
Запись.Тип = Перечисления.ТипыКонтактнойИнформации.Телефон;
ТекОбъект1 = ГлобОбъект1.НайтиПоКоду("00007");
Запись.Вид = ТекОбъект1.Ссылка;
Запись.Комментарий = "Перенесено ";
Запись.Представление = Код;
НаборЗаписей.Записать();
КонецЕсли;
Если Ком = "АдресВСтранеПроживания" Тогда
Запись = НаборЗаписей.Добавить();
Запись.Объект = ТекОбъект.Ссылка;
Запись.Тип = Перечисления.ТипыКонтактнойИнформации.Адрес;
ТекОбъект1 = ГлобОбъект1.НайтиПоКоду("00001");
Запись.Вид = ТекОбъект1.Ссылка;
Запись.Комментарий = "Перенесено ";
Запись.Представление = Код;
НаборЗаписей.Записать();
КонецЕсли;
Если Ком = "АдресПрописка" Тогда
Запись = НаборЗаписей.Добавить();
Запись.Объект = ТекОбъект.Ссылка;
Запись.Тип = Перечисления.ТипыКонтактнойИнформации.Адрес;
ТекОбъект1 = ГлобОбъект1.НайтиПоКоду("00002");
Запись.Вид = ТекОбъект1.Ссылка;
Запись.Комментарий = "Перенесено ";
Запись.Представление = Код;
НаборЗаписей.Записать();
КонецЕсли;[/indent]

ПРедалагают методом выгрузки этого набора в табличную часть потом редактирования и потом загрузки обратно
Но вот как раз это не получается .
ПромТабл = НаборЗаписей.Выгрузить();



Вот и прошу помощи
15 May 2008
Есть таблица значений в форме .Есть просто таблица значений .Каким образом увидеть её визуально .или загрузить через форму или саму
переменную таблицу значений в форме отразить.
Есть немножко кода
Колонки = ЭлементыФормы.ТаблицаПравил.Колонки;
Колонки.Очистить();
Колонки.Добавить("Тип");
Колонки.Добавить("Рек");
Колонки.Добавить("Рекк");

Колонки.Добавить("М");
Колонки.Добавить("Рек1");

Колонки.Добавить("М1");
Для Каждого СтрокаТаблицы Из ТаблицаПравилКонвертации Цикл
ЭлементыФормы.ТаблицаПравил.ДобавитьСтроку();

//Вот здесть как добраться до строки
КонецЦикла;
28 Mar 2008
Провожу документ .Вроде без ошибок .Отказ равен лжи выхожу отладчиком из процедуры "Обработка проведения ".А призакрытии документа говорит "операция не выпонена ". И также при отмене проведения .Смотрю отладчиком никаких
ошибок а все равно эффект тотже "Не выполнена " .Где искать ?Все предопределенные процедуры посмотрел.


17 Nov 2009 - 11:12


2 Nov 2009 - 0:29


9 Jun 2009 - 12:10


19 Mar 2009 - 18:47
WiG


19 Aug 2008 - 13:00

Cosmos.

.
RSS Текстовая версия Сейчас: 22nd July 2019 - 01:01