IPB

Здравствуйте, гость ( Вход | Регистрация )

 
Ответить в эту темуОткрыть новую тему
> Как к полю выбора прицепить список значений, поле ввода тоже рассматривается
ezh
сообщение May 18 2004, 12:05
Сообщение #1


Туманный ёжик
***

Группа: Эксперты
Сообщений: 618
Регистрация: 5-January 04
Из: г.Москва
Пользователь №: 1151



Работа с полем выбора

1Cv8
// 1. Установка списка значений для поля выбора
сп = Новый СписокЗначений();
сп.Добавить("Первый");
сп.Добавить("Второй");
ЭлементыФормы.ПолеВыбора.СписокВыбора = сп;

// 2. Установка значения по умолчанию
ЭлементыФормы.ПолеВыбора.Значение = сп[0].Значение;


Работа с полем ввода

1Cv8
// 1. Для поля ввода устанавливаем следующие свойства
// (в редакторе форм Конфигуратора)
// РежимВыбораИзСписка = Истина;
// КнопкаСпискаВыборка = Истина;

// 2. Привязка списка к полю ввода
сп = Новый СписокЗначений();
сп.Добавить("Третий");
сп.Добавить("Четвертый");
ЭлементыФормы.ПолеВвода.СписокВыбора = сп;

// 3. Установка значения по умолчанию
ЭлементыФормы.ПолеВвода.Значение = сп[0].Значение;


ПолеВыбора отличается от ПоляВвода сильно урезанным функционалом + возможностью задать список значений непосредственно в конфигураторе.
Рекомендуется по возможности применять для решений ПолеВвода.

Добавление от FatPanzer:
1Cv8
// 1. Установка списка значений для поля выбора в табличном поле
сп = Новый СписокЗначений();
сп.Добавить("Первый");
сп.Добавить("Второй");
ЭлементыФормы.ТабличнаяЧасть.Колонки.ПолеВыбора.ЭлементУправления.СписокВыбора = сп;


Добавление от zukoff:
1Cv8

Процедура ЗаполнитьСписокПеречислением(Элемент, Перечисление)     Экспорт
кол = Перечисление.Количество();
инд = 0;
Пока (инд < кол) Цикл
Элемент.СписокВыбора.Добавить(Перечисление.Получить(инд));
инд=инд+1;
КонецЦикла;
КонецПроцедуры

Процедура ЗаполнитьСписокСправочником(Элемент, Справочник, Сорт)  Экспорт
спр = Справочник.Выбрать(Справочник.ПустаяСсылка(),,,Сорт);
Пока (спр.Следующий()) Цикл
Если спр.ЭтоГруппа = ложь Тогда
 Элемент.СписокВыбора.Добавить(спр.Ссылка);
КонецЕсли;
КонецЦикла;
КонецПроцедуры

Процедура ЗаполнитьСписокГруппойСправочника(Элемент, Справочник,Группа, Сорт)  Экспорт
спр = Справочник.Выбрать(Группа,,,Сорт);
Пока (спр.Следующий()) Цикл
Если спр.ЭтоГруппа = ложь Тогда
 Элемент.СписокВыбора.Добавить(спр.Ссылка);
КонецЕсли;
КонецЦикла;
КонецПроцедуры

Использование:
1Cv8

ЗаполнитьСписокСправочником(ЭлементыФормы.тчТабЧасть.Колонки.Колонка1.ЭлементУправления, Справочники.Справочник1, "Код");

ЗаполнитьСписокСправочником(ЭлементыФормы.ПолеВвода1, Справочники.Справочник1, "Код");


и т.д.


--------------------
8.0.13.32
Вернуться в начало страницы
 
+Ответить с цитированием данного сообщения

Ответить в эту темуОткрыть новую тему
1 чел. читают эту тему (гостей: 1, скрытых пользователей: 0)
Пользователей: 0

 



RSS Текстовая версия Сейчас: 14th December 2017 - 11:14